Справочник по Debian



         

Устаревший способ обновления через apt-get


Использование apt-get, описанное ниже, широко распространено, но не рекомендуется для обновления системы.

Если Вам нужно обновиться без использования dselect в системах новее Woody, рассмотрите программу aptitude и прочие.

Если система не имеет много пакетов или архив Debian не сильно изменился, следующего может быть достаточно (иногда):

# apt-get update # всегда делается перед обновлением ... для обновления системы на основе зависимостей "depends": # apt-get upgrade # затем всегда делаем это ... для обновления в целом системы на основе информации о "depends"-зависимостях: # apt-get -u dist-upgrade ... или обновиться и придерживаться текущего выбора в dselect (новый и лучший способ): # apt-get -u dselect-upgrade # используем результат выбора в dselect

Так как этот способ обновления использует программу apt-get, то обработка зависимостей recommends и suggests ограничена. Смотрите .

[ ] [ ] [ ] [ ] [ ] [ ] [ 5 ] [ ] [ ] [ ] [ ] [ ] [ ] [ ] [ ] [ ] [ ] [ ] [ ]




Содержание  Назад